1 系统介绍 - PC帮助文档V2.1.0

1 系统介绍


1.1 系统简介 - PC帮助文档V2.1.0

1.1 系统简介

项目管理系统PC通过项目管理、管理视图、后台管理三个管理模块的相互作用形成完整的项目管理系统，三个模块各司其职快速高效的完成对整个项目的管理，从而获得高品质的项目产品。后台管理主要关注企业的组织分解结构和项目分解结构信息、包括对企业现在拥有的人力与非人力资源管理以及对过去商业客户信息维护，清晰明了的展示了资源使用的层级结构,方便了资源的维护；高层视图主要管理项目的立项以及该项目的缺陷流程定制，界面属性流程定制等为规范项目流程而做的配置管理与维护，以及还包括管理人员对所管理项目的资源使用情况、项目进度报告与质量分析信息统计管理；项目管理模块对整个项目的实施过程执行与监控进行管理帮助用户迅速建立完善的项目管理规范，从项目计划的建立、需求的分析、以及各过程的评审及进度管理等整个项目控制流程的管理。


1.2 功能介绍 - PC帮助文档V2.1.0

1.2 功能介绍

项目管理

支持项目的团队管理；支持字段属性自定义；支持根据模板创建项目。新版本新增了线上评审。

项目计划管理

支持项目计划（甘特图）、项目里程碑、项目资源分配等；支持项目计划分析，以日历形式显示资源在每个任务下的计划工期，及该资源的总计划工期，分析人力资源分配是否合理。

项目进度监控：显示项目进入实施状态的数据，通过跟踪甘特图显示当前项目的进度情况，包括当前进度下资源消耗情况、对比计划与实际进度情况、标识里程碑达成情况、标识项目范围完成情况等。

测试需求管理

支持测试需求管理、支持测试需求树，树的每个节点是一个具体的需求，也可以定义子节点作为子需求。

后台管理

企业管理（添加、修改和删除企业，添加、修改和删除供应商），资源管理（添加、修改和删除部门），用户管理（添加、删除用户），角色管理（添加、删除和修改角色信息、为不同的角色设置不同的权限），EPS管理（添加、修改和删除EPS），日历管理，数据字典（添加、删除和修改属性值）、邮件配置（配置邮件发送服务器，在处理缺陷时修改缺陷的状态，就可以通过自动发送邮件的形式发送给相关人员）。

测试分析

测试分析的目的是统计和分析测试结果，确定是否达到测试要求的指标。分析实际测试执行的有效性和充分性，分析测试执行是否完全；统计测试过程中的所有软件缺陷，列出每个缺陷的信息，并将缺陷的各种属性进行归纳分析。

测试缺陷管理

提供用户自由配置缺陷流程、新增缺陷、缺陷跟踪处理、生成缺陷统计报表等功能。

报告提交测试人员发现的bug并可以使用过滤器和添加搜索条件的方式查询所需要的bug。显示当前所有提交Bug的状态（确认、分配、修改完成等），同时统计报表中可以统计当前所有不同状态bug的数量以及所在模块的分布图。

报工管理模块

用于项目人员对作业报工的申请，然后项目经理对报工进行审批的一个过程。


1.3 服务支持 - PC帮助文档V2.1.0

1.3 服务支持

我们通过在线QQ、微信、电话、电子邮件为您提供支持与服务，您也可访问我们的网站http://www.spasvo.com/寻求帮助；为保证服务质量，确保有效地解决用户的问题，保障用户的项目实施进度，技术支持仅向授权用户和授权试用用户提供。请您在联系泽众技术支持时，告知您的单位名称和服务代码。

技术支持
 电话：021-60725088-8007

传真：021-60725088-8017
 电子邮件：support@spasvo.com

QQ：1404189128

泽众微信公众号

产品服务

有关培训、产品购买及试用授权方法的问题，请与销售代表联系，或联系泽 众咨询热线。

电话：021-60725088-8006

传真：021-60725088-8017

电子邮件: sales@spasvo.com


2 环境配置 - PC帮助文档V2.1.0

2 环境配置


2.1 硬件环境 - PC帮助文档V2.1.0

2.1 硬件环境

CPU：4核

内存：4G

硬盘：建议1T


2.2 软件环境 - PC帮助文档V2.1.0

2.2 软件环境

支持的操作系统：

windows2000/windows2003/windows2008/windows7/windows8

推荐的操作系统：

64位 window2003/windows7 操作系统

JDK1.7以上版本

IE9.0以上的浏览器、谷歌浏览器


3 安装配置说明 - PC帮助文档V2.1.0

3 安装配置说明

下面子章节详细介绍了PC的安装与配置说明。


3.1 PC安装说明 - PC帮助文档V2.1.0

3.1 PC安装说明


3.1.1 PC安装 - PC帮助文档V2.1.0

3.1.1 PC安装

建议PC的安装服务器做到专机专用，避免数据和性能上的问题。

特别说明：PC默认数据库服务名称是：mysql_PC 数据库服务端口：3305

点击PC的安装图标进入下一界面，点击下一步直至安装完成即可。

注意：已经装有MYSQL数据库、存在MYSQL服务的情况下，安装程序将会根据用户的选择来安装。

a) 安装PC MYSQL

1) 程序将自动安装默认数据库，安装完成后双击启动PC即可使用。

b) 不安装PC MYSQL

1) 程序将不安装数据库，不会对原有数据库造成任何影响。

2) 需专业数据库人员对PC进行数据库配置后方可正常使用PC。


3.1.2 安装Flash - PC帮助文档V2.1.0

3.1.2 安装Flash

下载最新版Flash安装包双击安装完成即可。

参考网站：

https://helpx.adobe.com/flash-player/kb/installation-problems-flash-player-windows.html


3.1.3 申请license - PC帮助文档V2.1.0

3.1.3 申请license

先点击“启动PC”图标，打开Tomcat服务器。然后点击开始菜单-泽众软件-PC2.1文件夹下的“申请PC licence”或在浏览输入http://localhost:8008/ProjectCenter/PCLicenseFlex.html网址直接,点击申请许可证，弹出申请许可证对话框，选择需要申请的使用时长，以及同时在线人数，点击确定按钮，即可导出申请license所需的req文件。

将导出的PC.req文件通过e-mail发送到 support@spasvo.com邮箱申请license


3.1.4 导入license - PC帮助文档V2.1.0

3.1.4 导入license

点击“申请PC licence”或在浏览器上访问http://localhost:8008/ProjectCenter/PCLicenseFlex.html页面，点击导入许可证，将技术支持回复的lic文件导入到系统内，导入成功后，重新启动PC，即可成功使用系统。（双击桌面“运行PC”图标进入PC。）


3.1.5 PC卸载说明 - PC帮助文档V2.1.0

3.1.5 PC卸载说明

注意：卸载PC时,程序会根据用户选择来卸载。

a) 卸载PC 数据库

1) 程序会完全删除PC数据库及服务,包括里面的数据。

2) 程序不会删除用户原有的MYSQL数据库及服务,不会影响用户数据库中的数据。

b) 不卸载PC 数据库

程序会删除PC程序体,不会删除PC MYSQL数据库及服务，不会影响数据库中的数据。

PS：如果卸载过程中选择不删除数据库，在备份数据后，又需要删除数据库，请重新覆盖安装PC后,执行卸载程序。

最终解释权归上海泽众软件有限公司。


3.2 PC配置说明 - PC帮助文档V2.1.0

3.2 PC配置说明

因为PC中某些功能开放程度比较大，我们需要进行相应的配置来完成项目管理的整个操作流程。


3.2.1 数据库配置 - PC帮助文档V2.1.0

3.2.1 数据库配置

当安装PC的时候未安装默认数据库时需要此配置首先找到PC安装目录下\PC\apache-tomcat-7.0.56\webapps\ProjectCenter\WEB-INF

找到 [image] 并用编辑软件打开进行修改即可（记事本即可）


3.2.2 PC文档管理SVN的配置 - PC帮助文档V2.1.0

3.2.2 PC文档管理SVN的配置

如果想要使用SVN文档管理功能时需要配置svn地址，步骤如下：

1）打开....\PC\apache-tomcat-7.0.56\webapps\ProjectCenter\WEB-INF\classes 安装目录

2) 修改“flowConfig.properties”中的四个配置

用户名（svn.username）、密码（svn.password）、地址（svn.url）要改成当前环境下要试用的svn、所选的svn地址下必须包含svn.pc_docs_rootname同名的文件夹

svn.username=zhaoxf

svn.password=222222

svn.url=svn\://192.168.1.200/testsvn/

svn.pc_docs_rootname=pc_projects


3.2.3 PC审批流程配置 - PC帮助文档V2.1.0

3.2.3 PC审批流程配置

目前系统默认配置的流程中包含的流程处理角色有测试工程师、测试负责人、需求负责人、项目经理，在创建的项目中，团队人员配置需要包含这四种角色，会出现评审流程没有相应的角色人需要重新配置，可参照下面的步骤配置。

可按照以下步骤自行配置各流程处理人

1)http://localhost:8008/ProjectCenter/test/test1.spa输入上面的网址，进到流程配置界面

2)在流程管理-流程配置中选中想要更改配置的流程，点击“配置流程”

3)在配置流程界面点击“配置”，为该流程的某个节点配置处理人。

注：

配置类型为项目角色，则该流程节点的处理人为项目中担任所选角色的用户；配置类型为项目用户，则该流程节点的处理人只能是所选的用户；组织角色类似于项目角色


4 新手上路 - PC帮助文档V2.1.0

4 新手上路


4.1 快速入门 - PC帮助文档V2.1.0

4.1 快速入门

首先我们按照章节3安装说明中成功安装了我们的ALM之后，我们就可以根据我们的快速入门进行一个操作使用了。


4.1.1 ALM技术简介 - PC帮助文档V2.1.0

4.1.1 ALM技术简介

ALM可以使 IT 人员能够管理核心应用程序生命周期，从通过部署的需求，授予应用程序团队现代应用程序的可预言、可重复和可适应传递所需的重要可见性和协作。

应用程序生命周期管理是一个复杂的过程。无论贵组织是以敏捷为主导还是同时采用迭代和连续方法，有效生命周期管理的目标都是提高可预测性、可重复性、改进质量以及随更改及时作出调整。交付经理可以通过了解项目里程碑、可交付版本、资源和预算需求以及跟踪项目进展状况、标准和质量指标实现上述目标。

该ALM通过项目管理和测试管理来覆盖完整的生命周期。


4.1.1.1 使用流程 - PC帮助文档V2.1.0

4.1.1.1 使用流程

ALM的项目管理使用流程由以下几个步骤组成：

1. 创建OBS。OBS用于对项目资源的统一调配。

2. 创建EPS。EPS管理模块用于对项目群的管理，所谓项目群管理就是将具有类似属性的若干项目放到一个集合中，并且给该项目群分配负责人，用于管理该项目群下的项目。

3. 分配权限。角色组是对角色权限的分类管理，相同的角色可以在不同的组中分配不同的权限。

4. 创建缺陷流程。项目管理人员可以在缺陷流程定制模块，进行缺陷流程的个性化配置，配置符合项目实际情况的缺陷流程。

5. 创建分类码。分类码包含项目分类码和作业分类码。项目分类码用于创建项目时给项目进行分类。作业分类码用于给项目计划的作业进行分类，并且在项目报表中，会根据作业分类码进行统计工时分析，比较不同类作业所占的工时比例是否正常。

6. 创建项目。前台的项目管理和测试管理均以此为单位，所以要创建项目。

7. 创建项目范围。项目范围定义了项目应该要做什么事，不该做什么事。

8. 添加项目合同。项目合同规范了项目的功能描述、研究开发计划和售后服务承诺等。

9. 添加项目人员。进行项目的团队管理，项目经理负责将项目其他成员加入项目，分配角色，这样成员登录系统才可看到相关项目信息。

10. 设置项目日历。设置项目日历是根据后台的日历为模板设置的，为项目中团队人员设置工作日和工作时间。

11. 进行需求管理。每一个项目的开始，都是由于需求的存在，项目要做的第一件事就是创建需求。

12. 项目计划管理。帮助项目经理和项目团队确定和有效地管理项目的工作。

13. 项目进度管理。ALM提供管理人员在项目实施过程中，通过报工系统，实时掌控项目计划的实施状况。

ALM的测试管理使用流程由以下几个步骤组成：

1) 测试计划管理。开发清晰、简要的测试计划是应用程序测试成功的基础。好的测试计划使您能够在应用程序管理过程中对任何时点的应用程序质量进行评估。

2) 测试用例管理。测试用例的目的是能够将软件测试的行为转化成可管理的模式。

3) 测试执行管理。开始执行测试。

4) 缺陷管理。有效定位和修复应用程序缺陷对开发流程非常重要。

5) 测试分析。用于分析和显示各种格式的 ALM 数据。

6) 报工管理。用于项目人员进行任务工时的提交及审批。


4.1.1.2 示例应用程序-CRM客户管理系统 - PC帮助文档V2.1.0

4.1.1.2 示例应用程序-CRM客户管理系统

为了说明 ALM 解决方案，本快速入手指南使用CRM客户管理系统示例。该客户管理系统下系统管理员管理系统用户、角色与权限，保证系统正常运行；客户经理对客户服务进行分配，指派、管理客户信息、客户联系方式、客户预定及相关文档；销售：维护负责的客户信息、创建客户信息、对处理的服务进行反馈、对特定销售机会制定客户开发计划、执行客户开发计划。

在这个快速入门课程中，您将通过 ALM的项目管理和测试管理流程完成CRM客户管理系统的生命周期管理的基本步骤。


4.1.2 项目管理 - PC帮助文档V2.1.0

4.1.2 项目管理

CRM管理系统的生命周期管理第一步是先进行项目管理。


4.1.2.1 如何进入到后台管理？ - PC帮助文档V2.1.0

4.1.2.1 如何进入到后台管理？

首先启动ALM服务，然后运行ALM，输入用户名与密码登录。

1.启动ALM服务

选择 开始 > 所有程序 > 泽众软件 > ALM2.0.2 >启动ALM或者点击桌面的启动ALM快捷方式。将启动ALM服务窗口。

2.运行ALM

选择 开始 > 所有程序 > 泽众软件 > ALM2.0.2 >运行ALM或者点击桌面的运行ALM快捷方式。将打开ALM窗口。

3.输入用户名与密码登录

使用用户名为manager密码为111111的账号进行登录，（不需要勾选下方模块，即便选择也会默认识别管理员账号）进入到后台管理界面。


4.1.2.2 如何创建OBS？ - PC帮助文档V2.1.0

4.1.2.2 如何创建OBS？

OBS用于对项目资源的统一调配。项目资源包括人工资源和非人工资源。创建人工资源就是创建用户。创建用户的目的就是用于测试项目和管理视图登录。

添加用户时要选择企业与部门，所以首先要添加企业，然后再添加部门，之后再添加用户。

1.添加企业

点击 [image] 【企业管理】，进入到企业管理模块下

点击 [image] 【添加】按钮，弹出添加企业对话框，依次输入企业名称、联系人、电话和邮箱，点击【确定】按钮，添加成功。

企业添加完之后，就要添加部门了。

2.添加部门

点击 [image] 【资源管理】进入到资源管理模块下

点击 [image] 【添加平级部门】按钮或选中一个部门节点，点击 [image] 【添加子部门】按钮，可以弹出部门对话框，输入部门名称、备注和办公电话，点击【确定】按钮，添加成功。

企业与部门都添加完之后，就可以添加用户了。

3.添加用户

点击 [image] 【用户管理】进入到用户管理模块下

添加用户有两种方式：1.手动添加用户；2.导入用户

手动添加用户：

点击 [image] 【添加用户】按钮，弹出创建项目用户账号对话框，输入账号、密码、真实姓名、Email、资源代码和单价，选择企业和部门，点击【保存】按钮，添加完成。

导入用户：

首先点击 [image] 【下载导入模板】按钮，下载导入用户的模板，在模板里输入用户信息。

然后点击 [image] 【导入用户】按钮，选择该模板进行导入，提示导入成功。


4.1.2.3 如何创建EPS？ - PC帮助文档V2.1.0

4.1.2.3 如何创建EPS？

EPS管理模块用于对项目群的管理，所谓项目群管理就是将具有类似属性的若干项目放到一个集合中，并且给该项目群分配负责人，用于管理该项目群下的项目。

用户创建完之后，就可以设置项目群负责人了。设置项目群负责人主要是为了在管理视图中创建项目和管理该项目群下的项目。

设置项目群负责人之前要添加项目群EPS，然后再设置负责人。

1.添加项目群EPS

点击 [image] 【EPS管理】进入到EPS管理模块下

点击 [image] 【添加根节点】按钮或者选中EPS，点击 [image] 【添加子节点】按钮，弹出添加页面，输入EPS名称和EPS编码，点击【确定】按钮，添加完成。

添加完项目群EPS之后，就要为项目群EPS设置负责人了。

2.设置EPS用户

选中项目群EPS，点击 [image] 【设置EPS用户】按钮，弹出设置EPS用户页面，选择部门下的用户，点击【添加】按钮，设置成功。

注：EPS负责人可以设置多个用户。


4.1.2.4 如何进行权限分配？ - PC帮助文档V2.1.0

4.1.2.4 如何进行权限分配？

创建项目之前一定要配置角色权限。每个项目有不同的角色，不同的角色有不同的权限。系统默认的角色组包括综合管理和项目管理。系统默认的角色包括测试员、测试负责人、开发负责人、开发工程师、需求负责人、业务负责人、EPS负责人和项目经理。

如果不想使用默认角色组，那就添加角色组，如果角色不够，可以添加角色，最后为角色分配权限。

1.添加角色组

点击 [image] 【角色管理】进入到角色管理模块下

点击 [image] 【添加角色组】按钮，弹出添加角色组页面，输入角色组名称，点击【确定】按钮，添加成功。

2.添加角色

点击 [image] 【添加角色】按钮，弹出添加角色页面，输入角色名称，选择角色类型：项目角色和综合管理角色，点击【确定】按钮，添加完成。

注：

角色类型选择综合管理角色，添加的角色只能在综合管理默认角色组显示；角色类型选择项目角色，添加的角色可以在所有的项目管理角色组显示。

3.分配权限

选中CRM角色组，勾选角色，勾选组件，点击 [image] 【保存】按钮，分配权限成功。

目前角色分配的权限如图所示：


4.1.2.5 如何进入管理视图？ - PC帮助文档V2.1.0

4.1.2.5 如何进入管理视图？

在登录页面输入用户名与密码登录。

因为在后台管理中已经设置了项目群EPS负责人，如果没有设置负责人可以看1.3.3操作。输入负责人用户名test与密码111111进行登录（需要勾选管理视图模块，不勾选默认进入到测试项目页面）进入到管理视图界面。

注：一定要勾选管理视图。


4.1.2.6 如何创建缺陷流程？ - PC帮助文档V2.1.0

4.1.2.6 如何创建缺陷流程？

进入到管理视图页面后，项目管理人员可以在缺陷流程定制模

块，进行缺陷流程的个性化配置，配置符合项目实际情况的缺流程，可以在创建项目时选择该缺陷流程。

点击【综合管理】-【缺陷流程定制】进入到缺陷流程定制页面

点击 [image] 【新增流程】按钮，弹出创建流程页。

选择在后台管理创建的角色组-CRM角色组，步骤如下：

1.点击 [image] 【添加】按钮，添加一个空流程节点

2.选择状态下拉框选中一个状态。状态下拉框下在状态选择项是在ALM【后台管理】-【数据字典】中进行配置的。

3.点击缺陷节点的角色列，弹出角色选择对话框，角色栏可选角色是角色组下的角色，勾选处理，勾选可以使缺陷进入第2步中选中的状态的角色。

4.点击目标状态，在弹出的状态选择对话框中，选择一个目标状态

注：开始状态与目标状态不能一致。

5.按照上面的过程，再添加其它节点。

注：要保证所有节点都有处理人、如果不正确的流程节点，可以选中后，点击 [image] 【删除】按钮，可以删除选中的流程节点

6.在配置完成流程后，输入名称，点击 [image] 【保存】按钮，保存缺陷流程。

注：缺陷流程是和角色组关联的。

举例：

现在想把CRM客户管理系统的缺陷流程如图所示：

配置完成后，截图如下：


4.1.2.7 如何创建分类码？ - PC帮助文档V2.1.0

4.1.2.7 如何创建分类码？

分类码包含项目分类码和作业分类码。项目分类码用于创建项目时给项目进行分类。作业分类码用于给项目计划的作业进行分类，并且在项目报表中，会根据作业分类码进行统计工时分析，比较不同类作业所占的工时比例是否正常。

点击【综合管理】-【作业分类码管理】进入到作业分类码管理页面

页面显示默认的项目分类码：软件测试和软件研发。项目分类码下显示默认的作业分类码。

1.新增项目分类码

点击 [image] 【新增组】按钮，弹出添加作业分类码组名称页面，输入名称，点击【确定】按钮，添加成功。

项目分类码添加完之后，就可以在项目分类码下添加作业分类码了。

2.添加作业分类码

选中组，点击 [image] 【新增分类码】按钮，弹出增加作业分类码页面，输入名称与说明，点击【确定】按钮，添加成功。

添加完之后如图所示：


4.1.2.8 如何创建项目？ - PC帮助文档V2.1.0

4.1.2.8 如何创建项目？

这时候创建项目前的准备都做好了。可以开始创建项目了。创建项目有两种方式：一是手动新增，二是模板创建项目。模板创建项目顾名思义就是根据模板项目来创建新的项目。我们选择手动新增项目的方式来创建项目。

点击【综合管理】-【项目管理】进入到项目管理页面

选中EPS节点:EPS-CRM，点击 [image] 【新增项目】按钮，弹出新增项目页面，输入项目名称、项目代码，选择状态-新建（根据项目目前所处状态选择项目状态，项目状态包括：新建、立项、实施、完成、结项），选择角色组-CRM角色组（后台管理创建），选择项目经理、缺陷流程、计划开始与结束时间、分类码组，是否线上评审-是、强关联-是，点击【确定】按钮，添加成功。

注：在项目没有提交缺陷的时候缺陷流程可以修改。


4.1.2.9 如何创建项目范围？ - PC帮助文档V2.1.0

4.1.2.9 如何创建项目范围？

项目范围定义了项目应该要做什么事，不该做什么事。所以在创建完项目之后，登录项目经理-test1用户，之后再进入综合管理-合同管理-项目范围去创建项目范围。

1.登录项目经理-test1

输入项目经理用户名test1与密码111111进行登录（需要勾选管理视图模块，不勾选默认进入到测试项目页面）进入到管理视图界面。

2.创建项目范围

点击【综合管理】-【合同管理】-【项目范围】进入到项目范围页面。

选择新增的项目-CRM项目，点击 [image] 【增加项目范围】按钮，弹出添加项目范围页面，选择【包含】或【不包含】，输入名称与描述，点击【确定】按钮，添加成功。

添加完【包含】与【不包含】项目范围后，如图所示：


4.1.2.10 如何创建项目合同？ - PC帮助文档V2.1.0

4.1.2.10 如何创建项目合同？

项目合同规范了项目的功能描述、研究开发计划和售后服务承诺等。

所以在创建项目范围之后，由项目经理test1创建项目合同。

点击【综合管理】-【合同管理】-【项目合同】进入到项目合同页面。

选择新增的项目-CRM项目，点击 [image] 【增加项目合同】按钮，弹出增加合同页面，输入合同名称、合同金额、合同类型、选择合同状态、生效日期、执行状态，输入备注，上传合同附件，点击【确定】按钮，添加成功。

注：一个项目可以有很多个合同。

项目添加完之后，合同编号自动生成。


4.1.2.11 如何添加项目人员？ - PC帮助文档V2.1.0

4.1.2.11 如何添加项目人员？

进行项目的团队管理，项目经理负责将项目其他成员加入项目，分配角色，这样成员登录系统才可看到相关项目信息，由项目经理test1添加项目人员。

点击【综合管理】-【项目管理】进入到项目管理页面。

选择新增的项目-CRM项目，点击 [image] 【项目团队管理】按钮，弹出项目用户管理页面。

添加项目成员步骤：

1. 选中角色（可以多选）

2. 选择部门，资源名称下会根据选中的部门显示部门下的资源

3. 选择资源

4. 点击 [image] 【添加用户】按钮，成功添加用户

添加完之后，如图所示：


4.1.2.12 如何设置项目日历？ - PC帮助文档V2.1.0

4.1.2.12 如何设置项目日历？

设置项目日历是根据后台的日历为模板设置的，为项目中团队人员设置工作日和工作时间。由项目经理test1设置项目日历。

点击【综合管理】-【项目管理】进入到项目管理页面。

选择新增的项目-CRM项目，点击 [image] 【设置项目日历】按钮，弹出日历设置页面。

该项目计划是1号开始、28号结束，所以我设置周六都是工作日，工作8小时。点击3、10、17、24，弹出自定义工作页面，选择工作，输入8小时，点击【确定】按钮，设置完成。

设置完之后，如图所示：


4.1.2.13 如何进入测试项目？ - PC帮助文档V2.1.0

4.1.2.13 如何进入测试项目？

有两种方式可以进入到测试项目。第一种直接在登录页面输入测试项目用户名与密码登录。第二种是直接点击【测试项目】按钮进入到测试项目中。

第一种：在登录页面输入测试项目用户名与密码登录。

因为在管理视图中已经添加了项目人员，输入项目人员用户名与密码，不勾选框，点击【登录】按钮，进入到任务中心/项目列表页面；勾选【 进入最近项目】，点击【登录】按钮，直接进入到最近一次登录操作的项目。

第二种：在管理视图页面直接点击【测试项目】按钮进入到测试项目中。


4.1.2.14 如何进行需求管理？ - PC帮助文档V2.1.0

4.1.2.14 如何进行需求管理？

测试需求来源于产品需求和开发需求，结合这两种需求能确保产品和用户需求一致，也能去除产品需求不合理的地方。测试需求的重要性可见一斑，它是整个测试的基石。因此如何做好测试需求管理也是整个项目管理的重要部门。

ALM内包含一套完善的测试需求管理系统流程，贯穿了整个测试需求的生命周期。

所以由项目经理在测试项目中管理测试需求。项目经理test1登录进入到测试项目，因为是第一次登录，所以不勾选框进行登录。按照4.1.2.13步骤进入到任务中心/项目列表中。

选择CRM项目，点击【进入项目】按钮，进入到测试项目中。

点击【测试需求】进入到测试需求页面

按照需求流程来对需求进行管理，步骤如下：

1.建立需求

建立需求由两种方式：一是：手动添加 ，二是导入Excel需求。

我选择手动添加需求方式来进行添加。手动添加需求：点击 [image] 【添加平级需求】或者选中【默认需求】，点击 [image] 【添加子需求】按钮，

弹出添加需求页面，输入需求名、需求名称，选择状态和优先级，输入内容，点击【确定】按钮，添加成功。

添加多个需求之后，需求页面如图：

注：根据需求规格说明书建立需求。

添加完需求后，要进行需求分析。

2.需求分析

需求分析是指理解用户需求，就软件功能与客户达成一致，估计软件风险和评估项目代价，最终形成开发计划的一个复杂过程。

要充分了解用户需求，就需要把需求分成多个功能点来进行详细的分析和了解。ALM可以在需求下添加功能点。

选中需求，点击 [image] 【新增功能点】按钮，双击功能名称输入名称和功能描述，点击 [image] 【保存】按钮，添加成功。

需求分析完成之后，就要进行需求评审了。

3.需求评审

需求评审是为了确定需求是否达到了规定目标的事宜性、充分性和有效性所进行的活动。

需求评审活动在【个人中心】-【评审中心】进行，点击【个人中心】-【评审中心】进入到评审中心页面。

点击“ [image] ”，发起一条需求评审流程，进入到发起流程页面。

输入备注，点击【添加需求】按钮，弹出选择需要评审的需求页面，选择刚刚新建的所有需求，点击【确定】按钮。

点击【提交】按钮，发起评审成功，处理结果是-测试负责人评审。输入测试负责人用户名test3，密码111111进入到CRM项目中，进入到【个人中心】-【评审中心】页面，点击【待处理流程】，进入到待处理流程页面。

点击 [image] 【评审】按钮，进入到处理页面。

可以点击【查看详细】按钮查看需求信息，查看了需求的详细信息之后，处理结果可以选择评审通过、评审拒绝（拒绝后需要修改需求，重新发起评审。）、同行评审（其他的测试负责人评审），选择处理结果-评审通过，点击【提交】按钮，评审完成。


4.1.2.15 如何进行项目计划？ - PC帮助文档V2.1.0

4.1.2.15 如何进行项目计划？

项目计划主要是列出项目活动过程中主要的工作和任务清单。通过项目计划，可以清楚的知道项目要做什么。项目管理人员可以在ALM的项目计划模块中根据项目实际情况为项目建立标准的WBS。帮助项目经理和项目团队确定和有效地管理项目的工作。可以在项目计划模块创建任务、添加里程碑，并且为任务添加作业分类码和资源，限定预期工期和设置预期时间计划，为任务添加关联等。编辑完项目计划完成之后，还要对项目计划评审。下面进入详细的操作：

点击【项目计划】-【项目计划】进入到项目计划页面。

选中项目节点，点击 [image] 【添加作业】按钮，双击名称可修改。点击 [image] 【添加里程碑】按钮，双击名称可修改。

注：

Ø 里程碑节点下不能新增作业

Ø 里程碑节点不计算工时和不占用资源

添加完作业和里程碑之后，双击作业前的序号，编辑作业信息。

1. 编辑作业的基本信息，为作业选择作业分类码，作业的完成百分比不可修改。

2. 切换到前置任务页面，编辑作业的前置任务，在输入框中输入想设置为该任务的前置任务的序号，点击 [image] 【添加】按钮，设置为前置任务，可以修改前置任务的类型关系和延隔时间。

3. 切换到任务资源页面，编辑作业的任务资源，点击 [image] 【添加】按钮为该任务添加资源，设置主要资源，双击资源占比，修改资源占比。

4. 切换到关联需求页面，点击 [image] 【关联】按钮，为该作业关联需求

双击里程碑前的序号，编辑里程碑信息。

1. 编辑里程碑的基本信息，修改开始时间、结束时间、完成百分比等信息。

2. 切换到前置任务页面，编辑里程碑的前置任务，在输入框中输入想设置为该里程碑的前置任务的序号，点击 [image] 【添加】按钮，设置为前置任务，可以修改前置任务的类型关系和延隔时间。

编辑作业和里程碑信息后，项目计划下的作业和里程碑信息如图所示：

编辑完项目计划完成之后，还要对项目计划评审。进入到【个人中心】-【评审中心】进入到评审中心页面，点击“ [image] ”，发起一条项目计划变更评审流程，进入到发起流程页面。

在该页面可以查看CRM项目的项目计划，点击【提交】按钮，发起评审成功，处理结果是-项目经理评审。

点击【待处理流程】，进入到待处理流程页面

点击 [image] 【评审】按钮，进入到评审页面。点击【提交】按钮，评审完成。


4.1.2.16 如何进行项目进度管理？ - PC帮助文档V2.1.0

4.1.2.16 如何进行项目进度管理？

良好的项目进度管理可以为项目经理做出决策以及预测项目是否能不超支且按时完成提供重要的信息。定期更新项目进度，以便记录项目进展情况，并发现潜在问题。

简而言之，项目进度模块可以管理项目的进度，在评审中心完成项目计划变更评审才能看到作业和里程碑等信息。项目经理test1点击【项目进度】进入到项目进度页面。

双击作业的工期和百分比来更新项目进度。


4.1.3 测试管理 - PC帮助文档V2.1.0

4.1.3 测试管理

【4.1.2项目管理】步骤完成之后，就要开始CRM客户管理系统的生命周期管理第二步：进行测试管理。


4.1.3.1 如何进行测试计划管理？ - PC帮助文档V2.1.0

4.1.3.1 如何进行测试计划管理？

开发清晰、简要的测试计划是应用程序测试成功的基础。好的测试计划使您能够在应用程序管理过程中对任何时点的应用程序质量进行评估。

登录测试负责人账用户名test3，密码111111进入到CRM项目中，点击【测试计划】进入到测试计划模块中。

测试计划管理包括了版本管理、测试计划管理、测试轮次管理等内容。

对测试计划管理的操作步骤如下：

1.创建版本

创建版本、计划和轮次有两种方式，一是手动添加，二是测试结构生成。我选择第一种方式。

选中【版本管理】，点击 [image] 【新增测试版本】按钮，弹出添加版本页面，输入版本名称、选择开始与结束时间，输入描述，点击【确定】按钮，版本添加成功。

注：通过版本可以控制你的测试进度。

2.创建计划

选中“CRM项目测试版本1”，点击 [image] 【新增测试计划】按钮，弹出添加计划页面，输入计划名称，选择计划开始时间与结束时间，输入测试目标与范围、测试策略、测试环境与描述，点击【确定】按钮，计划添加成功。

3.创建轮次

选中“功能测试计划1”，点击 [image] 【新增测试轮次】按钮，弹出添加轮次页面，输入轮次名称，选择开始时间与结束时间，输入描述，点击【确定】按钮，添加成功。

注：一个版本下可以有多个计划，一个计划下可以有多个轮次。

在设计完版本计划和轮次后，我们需要为不同版本关联对应的需求（我这只是创建了一个版本、计划和轮次，有需要可以再创建其他版本、计划和轮次）。

4.关联需求

选中“功能测试计划1”，点击【关联需求】，进入到关联需求页面

点击 [image] 【计划关联需求】按钮，弹出计划关联需求页面，勾选所有的需求，点击【确定】按钮，关联需求成功。

注：关联的需求，可以通过需求完成的情况来确定版本计划的测试进度、计划关联需求后，版本自动与需求关联，版本删除需求，计划自动删除需求。

关联需求成功后的页面如图所示：

接下来就是进行计划评审了。

5.计划评审

点击【个人中心】-【评审中心】进入到评审中心模块下，点击【计划评审】的“+”按钮。

进入到发起计划评审页面，点击【添加计划】按钮，勾选刚刚创建的计划，点击【确定】按钮。

输入备注信息，点击【提交】按钮，发起评审完成，处理结果是-测试负责人评审。

点击【待处理流程】进入到待处理页面，点击 [image] 【评审】按钮，进入到评审页面。点击【提交】按钮，评审完成。


4.1.3.2 如何进行测试用例管理？ - PC帮助文档V2.1.0

4.1.3.2 如何进行测试用例管理？

在实施测试时测试用例作为测试的标准，测试人员按照测试用例严格按测试步骤逐一实施测试。

ALM管理用例模式：

ALM将用例通过目录层级进行管理，目录结果和需求结构一致。通过用例和需求的关联，来保证需求的覆盖度。

ALM提供用户用例的导入导出功能，通过配置模版的方式，导入符合用户需求的用例。

登录测试工程师账号test4、test5、test7，密码111111进入到CRM项目中，点击【测试用例】进入到测试用例模块中。用户test4负责系统首页用例的编写，用户test5负责客户管理用例的编写，用户test7负责联络管理和文档管理用例的编写。

创建用例的方式有两种：一是手动添加、二是Excel导入用例。

选择Excel导入用例方式更方便。通过excel导入用例分为两种：1.通过需求编号导入用例；2.通过用例目录导入用例。因为CRM项目是用例-需求强关联项目，则必须通过需求编号导入用例。

注：

该方法导入用例，在配置导入模板的时候，一定要配置需求编号，且导入用例的需求编号对应的需求已经存在于需求列表中。通过这种方法导入的用例，自动和需求进行绑定。

现在需要导入如下格式的用例：

那么先进行导入模板配置。

步骤如下：

1.导入模板配置

点击 [image] 【导入模板配置】进入到用例导入配置页面，选择目录分割符、输入起始行、起始页、结束页，选择属性，输入对应列，点击 [image] 【添加】按钮，最后，点击【保存模板】按钮，配置成功。

注：

ALM所有导入模板中起始行是以2为起点的，起始页和结束页是以1位起点的。

目录名必须配置

配置完导入模板后，现在就可以导入用例了。

2.导入Excel用例

点击 [image] 【导入用例】按钮，选择需要导入的excel，可以进行用例导入。

注：

用例导入不会覆盖掉原有的用例，只是对没有的用例进行新增。

按照上述步骤，用户test4、test5、test7进行导入用例操作，导入完成之后，测试用例页面显示如图：

用例导入之后，测试工程师test4、test5、test7要对用例发起评审。进入到【个人中心】-【评审中心】页面，点击用例评审的“+”按钮

进入到发起用例评审页面，点击【添加用例】按钮，弹出选择需要评审的用例页面，勾选自己新建的用例，点击【确定】按钮，选择用例成功。

点击【提交】按钮，评审发起成功，处理结果是-测试负责人评审。

之后是测试负责人test3对发起的评审进行评审。进入到【个人中心】-【评审中心】-【待处理流程】页面。

点击 [image] 【评审】按钮，进入到评审页面。选择处理结果：评审通过，点击【提交】按钮，评审完成。


4.1.3.3 如何进行测试执行管理？ - PC帮助文档V2.1.0

4.1.3.3 如何进行测试执行管理？

进行测试执行管理，就是执行测试用例。执行测试用例之前需要将测试用例和轮次关联，然后用例分配执行人，之后执行人执行分配的用例。下面进行详细介绍：

1.测试用例与轮次关联

关联方式有两种，一是轮次直接添加用例，二是测试集添加用例，轮次添加测试集。

测试负责人test3进入到【测试计划】下，选中“功能测试第一轮”轮次，点击 [image] 【添加用例】按钮，弹出关联用例页面，勾选所有的用例，点击【确定】按钮，关联成功。

2.用例分配执行人

用例与轮次关联成功后，就可以为用例分配执行人。系统首页的用例分配给测试工程师test5执行、客户管理页面的用例分配给test7执行、联络管理和文档管理页面的用例分配给test4执行。点击 [image] 【分配执行人】按钮，弹出选择用户界面，指定执行日期，双击测试工程师或者选中测试工程师点击【确定】按钮，分配执行人成功。

分配执行人之后，轮次下用例如图所示：

3.执行人执行分配的用例

轮次用例分配给测试工程师后，测试工程师就可以执行用例。就拿测试工程师test5来举例，点击【个人中心】-【执行用例】进入到执行用例页面，页面只显示已经分配给test5的系统首页用例。

那怎么执行用例呢？步骤如下：

选中一条待执行或者已执行的用例，根据用例的步骤和数据来操作CRM客户管理系统，选择执行状态，输入实际结果、输入执行描述，点击【保存】按钮，用例执行成功。

注：

执行状态选择“未通过”时，会在界面上出现一个按钮-【提交缺陷】，进入缺陷提交页面，输入缺陷相关要素，点击【确定】按钮。此时在缺陷视图会新增一条新的缺陷，并且这条缺陷和该条用例是进行关联的。（如何提交缺陷，详情请看4.1.3.4。）


4.1.3.4 如何进行缺陷管理？ - PC帮助文档V2.1.0

4.1.3.4 如何进行缺陷管理？

缺陷管理是在软件生命周期中识别、管理、沟通任何缺陷的过程（从缺陷的新建到缺陷的解决关闭），确保缺陷被跟踪管理而不丢失。

进行测试执行（具体操作看4.1.3.4）就会有缺陷，缺陷的管理流程如下：

下面进行详细介绍。

定义缺陷管理流程：具体操作可以看4.1.2.6。

执行用例，提交缺陷：我们这里提交缺陷主要有两种方法：一种是在【个人中心】→【执行用例】中，当执行状态为未通过时，会出现“提交缺陷”按钮，点此按钮进行缺陷提交，具体操作可以看4.1.3.3，二是进入【缺陷视图】中，点击 [image] 【提交缺陷】按钮，出现提交缺陷对话框，输入缺陷名称与缺陷描述，选择处理人、严重等级、最后期限、关联用例、缺陷类别，点击【确定】按钮，缺陷提交成功。

缺陷跟踪。

缺陷处理人-开发工程师test8进入个人中心-缺陷处理模块进行处理缺陷，缺陷处理完成后，缺陷会进入下一个处理人的个人中心-缺陷处理模块中。

处理缺陷的步骤如下：

1.选中一条缺陷，单击缺陷名称，进入缺陷详情界面

2.选择下一步状态

注：

状态下拉框内的值是根据缺陷处理流程配置显示的

3.选择处理角色

注：

角色下拉框内的选项是根据选择的状态进行反显的。比如说在缺陷流程配置的时候，正在修改状态有项目经理、开发工程师可以操作，那么如果状态选择了正在修改，角色可选项就只有项目经理和开发工程师。

4.选择处理人

注：

处理人下拉框选择项是和角色关联的

5.点击【提交】按钮，让缺陷进入缺陷流程定制的下一个流程节点

6.下一个节点处理人同样到个人中心-缺陷处理模块处理缺陷，直到缺陷进入流程中配置的终止状态为止。


4.1.3.5 如何进行测试分析？ - PC帮助文档V2.1.0

4.1.3.5 如何进行测试分析？

测试分析的目的是统计和分析测试结果，确定是否达到测试要求的指标。分析实际测试执行的有效性和充分性，分析测试执行是否完全；统计测试过程中的所有软件缺陷，列出每个缺陷的信息，并将缺陷的各种属性进行归纳分析；根据用例的执行情况对软件进行分析，列出用例的生产率、手工执行率、需求分析率。

点击 [image] 进入到测试分析页面，可以查看各类缺陷报告、PCB指标、TPI指标等。缺陷报告统计测试过程中的所有软件缺陷，列出每个缺陷的信息，并将缺陷的各种属性进行归纳分析，自动生成缺陷报告。TPI指标显示TPI信息汇总表、用例生产率表、手工用例执行率表和需求分析率表。PCB指标显示显示PCB指标基本信息表、缺陷遗留率（缺陷全部未关闭、每日新增、每日关闭图形）、模块-缺陷分布柱状图、缺陷停留时间柱状图。


4.1.3.6 如何进行报工管理？ - PC帮助文档V2.1.0

4.1.3.6 如何进行报工管理？

报工其含义就是表达项目人员填报或上报项目工时及内容。工时系统就是用于项目人员对作业报工的申请，然后项目经理对报工进行审批的一个过程。举个例子，测试工程师test5在CRM项目中进行了用例执行用了4个小时。那现在开始进行报工，然后项目经理test1对其进行审批。步骤如下：

1.提交报工

测试工程师test5进入【工时系统】页面，选择CRM项目

点击02日（测试工程师test5在02日完成了用例执行），弹出编辑报工页面，在作业分类码后输入报工时长，点击【确定】按钮，提交报工成功。

2.审批报工

测试工程师test5提交报工之后,项目经理test1进入到【管理视图】-【工时系统】页面，选中CRM项目，可以看到测试工程师test5在2018-02-02显示4，代表着待审批-用例执行：4，点击【通过】或者【驳回】按钮，报工审批完成。


5 后台管理 - PC帮助文档V2.1.0

5 后台管理

PC项目管理系统分为后台管理、管理视图和测试项目界面，后台管理界面只允许管理员用户登录，管理员登陆系统的主要目的是创建企业、部门、EPS、用户、角色组等，管理视图只允许有权限的综合管理角色用户登录，主要目的是创建项目和对项目进行管理和掌控；测试项目界面主要是项目用户登录前台界面进行操作的。后台管理、管理视图和测试项目登录界面为同一个，登录地址为：http://localhost:8008/ProjectCenter/newlogin.jsp


5.1 企业管理 - PC帮助文档V2.1.0

5.1 企业管理

管理员登录后台系统：

登录界面如下：

输入用户名manager,密码spasvodemo，登录成功后，就是【企业管理】页面，企业管理界面如下：

点击【企业管理】进入到企业管理模块，企业管理模块分为企业管理和供应商管理。企业管理下主要是添加、修改和企业等操作，供应商管理下主要是对供应商进行添加、修改和删除等操作。


5.1.1 添加企业 - PC帮助文档V2.1.0

5.1.1 添加企业

进入到【企业管理】页面，点击点击 [image] 添加图标，进入创建企业界面，输入相关信息，点击确定按钮，企业添加完成。


5.1.2 添加供应商 - PC帮助文档V2.1.0

5.1.2 添加供应商

进入到【供应商管理】页面，点击点击 [image] 添加图标，进入创建供应商界面，输入相关信息，点击确定按钮，供应商添加完成。


5.2 资源管理 - PC帮助文档V2.1.0

5.2 资源管理

点击【资源管理】进入资源管理模块，该模块包括部门管理和资源管理。

部门管理：对部门的增、删、改、查操作。通过新增部门，将系统的资源和部门进行绑定，用于项目资源消耗统计。

资源管理：资源包含了人工资源、非人工和材料3样资源，此处只能增加非人工和材料资源，人工资源用户管理处增加。增加完资源后，可以对资源进行修改和删除操作。


5.2.1 添加部门 - PC帮助文档V2.1.0

5.2.1 添加部门

点击 [image] 添加平级部门图标，进入创建平级部门页面，输入部门信息，点击确定按钮，平级部门添加完成。

选中部门，点击 [image] 添加子部门图标，进入创建子部门页面，可在部门下添加子部门，输入子部门信息，点击确定按钮，子部门添加完成。


5.2.2 添加非人工/材料资源 - PC帮助文档V2.1.0

5.2.2 添加非人工/材料资源

选中部门或不选中部门，点击 [image] 添加图标，进入创建非人工/材料资源界面，输入相关信息，点击确定按钮，非人工资源添加完成。


5.3 用户管理 - PC帮助文档V2.1.0

5.3 用户管理

点击【用户管理】进入用户管理模块，用户管理模块主要是对项目用户进行添加、修改、删除以及用户导入等操作管理。


5.3.1 添加用户 - PC帮助文档V2.1.0

5.3.1 添加用户

点击 [image] 添加用户图标，进入创建项目用户界面，输入相关信息，其中Email为你在项目中接收邮件的地址，点击保存生成项目用户，当然也可以勾选“连续添加用户”连续添加。


5.3.2 修改用户 - PC帮助文档V2.1.0

5.3.2 修改用户

勾选需要修改的用户，点击 [image] 修改用户图标，可修改用户的基本信息，重置密码则可将用户密码重置为111111。


5.4 角色管理 - PC帮助文档V2.1.0

5.4 角色管理

点击【角色管理】进入角色管理模块，角色管理模块主要有两种角色组，分别为综合管理角色组和项目管理角色组。角色管理模块主要是对角色组和角色进行添加、修改、删除以及对角色分配权限等操作管理。


5.4.1 添加角色组 - PC帮助文档V2.1.0

5.4.1 添加角色组

点击 [image] 添加角色组图标，进入创建项目管理角色组页面，输入角色组名称，点击确定按钮完成添加，当然也可以勾选“连续添加”连续添加。


5.4.2 添加角色 - PC帮助文档V2.1.0

5.4.2 添加角色

点击 [image] 添加角色图标，进入创建角色页面，输入角色名称，选择角色类型：项目角色和综合管理角色，点击确定按钮完成添加，当然也可以勾选“连续添加”连续添加。


5.4.3 修改角色组 - PC帮助文档V2.1.0

5.4.3 修改角色组

选中需要修改信息的非默认角色组，点击 [image] 修改角色组图标，可修改角色组信息。


5.4.4 修改角色 - PC帮助文档V2.1.0

5.4.4 修改角色

选中需要修改信息的角色，点击 [image] 修改角色图标，可修改角色信息。


5.4.5 分配权限 - PC帮助文档V2.1.0

5.4.5 分配权限

每个角色都有各自的权限，勾选角色，勾选组件，点击保存按钮，保存角色下的权限。


5.5 EPS管理 - PC帮助文档V2.1.0

5.5 EPS管理

点击【EPS管理】进入EPS管理模块，EPS管理模块用于对项目群的管理，所谓项目群管理就是将具有类似属性的若干项目放到一个集合中，并且给该项目群分配负责人，用于管理该项目群下的项目。

EPS管理模块主要是对EPS进行添加、删除和修改以及为EPS设置用户等操作。


5.5.1 添加EPS - PC帮助文档V2.1.0

5.5.1 添加EPS

点击 [image] 添加根节点图标，进入创建EPS页面，输入EPS信息，点击确定按钮完成添加。

选中EPS，点击 [image] 添加子节点图标，进入创建子EPS页面，输入EPS信息，点击确定按钮完成添加。


5.5.2 修改EPS - PC帮助文档V2.1.0

5.5.2 修改EPS

选中需要修改信息的EPS，点击 [image] 修改图标，可修改EPS信息。


5.5.3 设置EPS用户 - PC帮助文档V2.1.0

5.5.3 设置EPS用户

选中需要设置用户的EPS，点击 [image] 设置EPS用户图标，进入到设置EPS用户页面，可以选择部门下的用户进行添加，该操作是为EPS设置EPS负责人。


5.6 日历管理 - PC帮助文档V2.1.0

5.6 日历管理

点击【日历管理】进入日历管理模块，日历管理模块主要是作为一个日历模板，可以自定义工作日工作几小时和非工作日，也可以修改一周的工作时间。


5.7 数据字典 - PC帮助文档V2.1.0

5.7 数据字典

点击【数据字典】，进入数据字典模块，这里主要是对项目模块单选属性，对属性值进行添加、删除和修改的操作。

详细操作：见下图


5.8 邮件配置 - PC帮助文档V2.1.0

5.8 邮件配置

进入【邮件配置】，这里主要是配置邮件发送服务器（在邮件配置界面，设置邮件发送服务器的协议类型、发送服务器地址、登陆帐号、密码、选择是否加密、端口、URL连接地址；该邮件配置后，在处理缺陷时修改缺陷的状态，就可以通过自动发送邮件的形式发送给相关人员。

限制：用户为系统管理员用户

详细操作：见下图

邮件配置完成保存以后，点击邮件发送测试，发送成功，则邮件配置正确。


6 管理视图 - PC帮助文档V2.1.0

6 管理视图


6.1 综合管理 - PC帮助文档V2.1.0

6.1 综合管理

有权限的综合管理角色用户登录管理视图：

登录界面如下：

登录成功后，就是【综合管理】页面，综合管理界面如下：

点击【综合管理】进入到综合管理模块，综合管理模块分为项目管理、合同管理、文档管理、计划模板管理、属性定制、缺陷流程定制。项目管理下主要是对项目进行添加、修改和删除等操作，文档管理主要是对文档进行上传、下载等操作，属性定制主要是自定义属性，缺陷流程定制主要是对流程进行添加、修改和删除等操作。


6.1.1 项目管理 - PC帮助文档V2.1.0

6.1.1 项目管理

点击【项目管理】进入项目管理模块，项目管理模块主要是对项目进行新增、修改、删除项目以及项目团队管理等操作。


6.1.1.1 新增项目 - PC帮助文档V2.1.0

6.1.1.1 新增项目

选中EPS节点，点击 [image] 新增项目图标，进入创建项目界面。

其中项目名称，项目代码，项目经理，计划开始时间，计划结束时间，缺陷流程为必填项，最后点击确定按钮，即可成功创建项目！

项目创建成功后，可在项目列表中查看新建的项目信息。


6.1.1.2 项目团队设置 - PC帮助文档V2.1.0

6.1.1.2 项目团队设置

在一个项目开始最初，都要进行项目团队的设置，在团队设置完成的基础上，我们才可以开始整个项目的下一步实施。

项目团队建设流程：

选中项目，点击 [image] 项目团队设置图案，进入到项目团队设置页面。

添加用户：选择角色(可以多选)->选择用户->点击 [image] 图标，把用户添加到项目中

修改用户角色：选择用户->选择角色(可以多选)->点击 [image] 图标，修改用户角色

删除用户：选择项目中的用户.点击 [image] 图标 删除后,该用户不会在该团队中

邮件订阅：选择用户->点击 [image] 图标，在系统提交缺陷的时候,会把缺陷的内容发送到邮件中.起到提醒用户功能

邮件取消：选择用户->点击 [image] 图标 ,取消后,将不再有邮件提醒的功能


6.1.2 合同管理 - PC帮助文档V2.1.0

6.1.2 合同管理

点击【合同管理】进入合同管理模块，合同管理模块包含项目范围和项目合同。项目范围主要是对项目范围进行增加、删除和修改，项目合同主要是对项目的合同进行增加、删除和修改。


6.1.2.1 项目范围 - PC帮助文档V2.1.0

6.1.2.1 项目范围

点击【项目范围】模块，进入到项目范围模块

选中一个项目节点，点击增加按钮，进入添加项目范围页面，输入信息，点击确定按钮项目范围添加完成，当然也可以勾选“连续添加”连续添加。


6.1.2.2 项目合同 - PC帮助文档V2.1.0

6.1.2.2 项目合同

点击【项目合同】模块，进入到项目合同模块

选中项目，点击增加按钮，进入到增加合同页面

导入项目合同文件，选择项目合同状态：有效、无效和待定。点击保存按钮，合同添加完成。


6.1.3 文档管理 - PC帮助文档V2.1.0

6.1.3 文档管理

点击【文档管理】进入到文档管理模块，文档管理模块提供项目管理人员在对整个项目生命周期的文档分类线上管理。支持文档的上传、下载、更新、文档任务的创建、归档、将文档分配到任务等操作。

节点分为根节点、项目节点、文档节点。

根节点有两个：已归档项目、开发中项目。已归档项目无法添加子节点下面的所有操作介绍是基于开发中项目下节点进行介绍的；开发中项目下面可以添加项目节点。

在项目开始之前，都会上传文档，接下来进行上传文档操作

选择文档导入，选择文档的类别：交付物、项目文档，点击保存按钮，文档上传完成，上传之后可以在测试项目-个人中心-文档管理模块下查看该文档。


6.1.4 计划模板管理 - PC帮助文档V2.1.0

6.1.4 计划模板管理

计划模版管理模块是把比较有代表性的项目计划转为计划模版，方便其它项目快速的创建项目计划。

点击【计划模板管理】进入到计划模板管理模块，计划模版管理模块主要包括了项目转换模版、导入模版、导出模版、修改模板名称、删除模版等功能。


6.1.5 属性定制 - PC帮助文档V2.1.0

6.1.5 属性定制

为了使工具更加贴近项目的实际需要，这里我们需要用到【属性定制】。（注：一旦项目定制了属性，就不能修改了），点击【属性定制】进入属性定制模块

首先新增模板，点击 [image] 新增模板图标，进入到添加模板页面，输入模板名称，点击确定按钮，模板添加完成。

然后新增属性，选中模板，点击 [image] 新增属性图标，进入到添加模块属性页面。

可以添加自定义属性的模块有：测试计划、测试需求、测试用例、缺陷视图、项目属性等。

自定义属性有三种类型：textinput、combobox、date。

Ø Textinput是添加一个文本输入框

Ø Combobox添加的是下拉选择框，必须添加默认值，选项之间用英文格式的“;”隔开

Ø date添加的是一个时间输入框

自定义属性可以设置是否在模块中显示，设置为在模块中显示，该自定义属性会在对应的模块中出现。如果设置为不显示，相当于让该自定义属性不生效，不在模块中出现。

自定义属性可以进行是否必输项设置，如果设置为必输项，自定义属性必须填写。如果设置为非必输项，在进行对应模块操作的时候，不进行该自定义属性是否填写的校验。

输入属性信息后，点击保存按钮，属性完成添加。


6.1.6 缺陷流程定制 - PC帮助文档V2.1.0

6.1.6 缺陷流程定制

在测试过程中，发现缺陷是必然的，那么，怎么规范合理地处理跟踪缺陷？这里我们需要用到【缺陷流程定制】。

（注：这里的缺陷流程定制就是在项目开始的时候定制的，一旦项目提交过缺陷以后，这里的缺陷流程便无法更改。）

点击【缺陷流程定制】进入缺陷流程定制模块

点击 [image] 新增流程图标，进入到创建流程页面

选择角色组，输入流程名称，点击添加按钮添加缺陷流程步骤，以下会给出一个完整的缺陷流程定制过程：

通过设置状态，角色，目标状态，设置缺陷流程，点击“保存”完成缺陷流程的定制。

此处定制完成后的缺陷流如下：

首先，测试工程师新建缺陷→测试负责人确认缺陷→开发负责人分配缺陷→开发工程师修改，修改完成→测试工程师关闭缺陷；开发负责人分配缺陷后→开发工程师驳回缺陷→测试工程师重开→开发工程师修改，修改完成→测试工程师再次重开→开发工程师驳回→测试工程师关闭缺陷。

点击保存按钮，流程添加完成。


6.2 工时系统 - PC帮助文档V2.1.0

6.2 工时系统

点击【工时系统】进入到工时系统模块，工时系统模块包含工时审批模块。工时审批模块，用于管理人员对项目人员的工时的审批。

选中项目，会显示项目中所有人的每一周的报工情况，进行审批，点击通过或者驳回，完成审批。


6.3 项目报表 - PC帮助文档V2.1.0

6.3 项目报表

点击【项目报表】进入到项目报表模块。项目报表模块包含项目资源曲线、部门资源曲线、企业资源曲线和项目状态表模块。


6.3.1 项目资源曲线 - PC帮助文档V2.1.0

6.3.1 项目资源曲线

点击【项目资源曲线】进入到项目资源曲线模块，勾选至少一个项目，点击搜索按钮。项目资源工期实际-计划对比折线图，X轴显示与选择的项目、月/年有关，Y轴与选择的项目的总报工（小时）有关。

注：

项目中当一个资源在多个任务上时工时是累加的，在多个项目中同时担任工作时也是累加的。


6.3.2 部门资源曲线 - PC帮助文档V2.1.0

6.3.2 部门资源曲线

点击【部门资源曲线】进入到部门资源曲线模块，勾选至少一个部门，点击搜索按钮。

部门资源工期折线图、部门资源使用百分比折线图，X轴与选择的部门中绑定的资源在此项目经理用户下的所有项目作业对应的起末时间和月/年有关，Y轴与选择的部门中绑定的资源在此项目经理用户下的所有项目作业对应的报工（小时）有关。

使用百分比：显示部门实际使用百分比=部门实际报工小时数/（部门人数*每天标准工作小时数）这种情况是系统有了作业参与百分比功能时使用

目前使用：显示部门实际使用百分比=部门实际报工小时数/（每人每天参与的task*每天标准工作小时数（项目的日历））

部门资源使用百分比=实际工期/计划工期


6.3.3 企业资源曲线 - PC帮助文档V2.1.0

6.3.3 企业资源曲线

点击【企业资源曲线】进入到企业资源曲线模块，勾选至少一个企业，不超过3个企业，选择形式：曲线，点击搜索按钮。根据企业、月/年、时间，查询显示相应的报表信息，X轴与选择的企业对应的资源在此项目经理用户下所有项目作业对应的起末时间和月/年有关，Y轴与选择的企业对应的资源在此项目经理用户下的所有项目作业对应的报工（小时）有关，点击时间的左右按钮可查看相应时间的折线图。

当形式选择表单时，根据企业、月/年、时间，查询显示相应的表单信息，显示出了企业下每个资源的所有项目的每天的报工（小时），点击时间的左右按钮可查看相应时间的折线图。


6.3.4 项目状态表 - PC帮助文档V2.1.0

6.3.4 项目状态表

点击【项目状态表】进入到项目状态表模块，显示登录用户的新建项目和加入项目的状态、工期完成百分比、时间完成百分比、计划工期、实际工期、计划开始时间、计划结束时间、实际开始时间和实际结束时间。

相关名词解释：

状态 | 显示对应项目的状态
名称 | 显示对应项目的名称
工期完成百分比 | 显示对应项目的工期完成百分比；比值=实际工期/计划工期
时间完成百分比 | 显示对应项目的时间完成百分比；比值=（计划结束-计划开始）/(实际结束-实际开始)
计划工期 | 显示对应项目的计划工期，为计划结束时间与计划开始时间时间段
实际工期 | 显示对应项目的实际工期
计划开始 | 显示对应项目的计划开始时间
计划结束 | 显示对应项目的计划结束时间
实际开始 | 显示对应项目的实际开始时间
实际结束 | 显示对应项目的实际结束时间


6.4 测试报表 - PC帮助文档V2.1.0

6.4 测试报表

点击【测试报表】进入到测试报表模块。测试报表模块包含仪表盘、自定义查询报表、数据项和报表管理模块。测试报表主要是项目群管理人员根据项目进行查看各项目的缺陷报表、各种测试指标、自定义报表等。方便项目管理人员实施把控各项目的进度情况。


6.4.1 仪表盘 - PC帮助文档V2.1.0

6.4.1 仪表盘

点击【仪表盘】进入到仪表盘模块。仪表盘以项目为单位，给项目群管理人员进行缺陷基本信息、项目人员报告统计。

缺陷基本信息统计：根据选中的项目，以图形的形式显示缺陷基本信息，有缺陷状态统计图、缺陷严重等级统计图、缺陷类别统计图。

缺陷状态统计图：根据缺陷的状态进行统计各种状态的缺陷的数量

缺陷严重等级统计图：根据缺陷的严重性进行统计

缺陷类别统计图：根据缺陷的类别进行统计

项目人员报工统计：根据选中的项目，以列表的形式，对项目中人员提交的缺陷与执行的用例进行统计，有执行用例与报告缺陷统计表、日执行用例与报告缺陷统计表。

执行用例与报告缺陷统计表：根据项目中每个项目人员执行用例与报告缺陷的统计数量

日执行用例与报告缺陷统计表：根据项目中每个项目人员每日执行用例与报告缺陷的统计数量


6.4.2 自定义查询报表 - PC帮助文档V2.1.0

6.4.2 自定义查询报表

点击【自定义查询报表】进入到自定义查询报表模块。自定义查询报表模块是以自身定义的内容形成一份报表，展现软件各个方向的性能。主要包括了新增、删除和修改报表等功能。

点击新增报表按钮，进入到新增报表页面，对自定义报表进行编辑，制作成用户自己想要看到的自定义报表。

功能点描述：

所有数据项 | 以树装列表的形式，展现所有的数据项
报表名称 | 在名称后的方框中编辑报表的名称，供自定义报表中报表名称栏显示
保存报表 | 在报表编辑完成后，对报表进行保存
添加数据项列表 | 以树状列表的形式展现数据项，并对数据项进行增删改查，包含的信息有ID、名称
添加数据项 | 选中一个或多个所有数据项中的数据，点击【添加数据项】，将所有数据项中的数据，添加到报表中
删除数据项 | 选中添加过后的数据项，点击【删除数据项】，删除该数据
设置筛选条件 | 为报表信息输出设置筛选条件，将用户想要输出的信息筛选出，包含的信息有类型、字段、条件、值、开始、完成
预览查询结果 | 筛选条件创建完成后，可对筛选出的信息进行预览，让用户提前看到筛选的结果，不需要在筛选完成后再回过头来调整筛选条件
删除筛选条件 | 删除以前创建的筛选条件
设置关联和显示 | 设置该报表的关联的字段为该报表完善报表信息，无论是流程前字段还是流程后字段，让用户能更好的了解到创建报表的前因后果，设置显示那些字段，设置关联包含内容“字段”，显示内容包含“类别和系列”
新增关联 | 完成设置筛选条件后，点击【新增关联】调出创建关联界面，添加关联字段点击【确定】确认添加，点击【取消】该操作
删除关联 | 选中列表中的关联，点击【删除关联】删除选中关联。
类别 | 通过点击【下拉框】调出“类别”和“聚合类型”
系列 | 设置显示的系列为什么内容，内容包含系列、别名
新增系列 | 点击【新增系列】调出筛选该系列的筛选器，设置筛选条件“字段”和“别名”点击【确定】确认该次添加，点击【取消】则放弃本次操作
删除系列 | 选中添加的系列，点击【删除系列】点出提示框，点击【确定】确认该次操作，删除选中系列，点击【取消】，放弃本次操作


6.4.3 数据项 - PC帮助文档V2.1.0

6.4.3 数据项

点击【数据项】进入到数据项模块。数据项模块是对项目管理工作中的各项数据进行管理，支持自由定制其他标准的数据项，进而生成符合各项标准的项目报表/文档。主要含括了新增、修改和删除分组和数据项的功能。

选中数据源分类，点击新增数据项按钮，进入到新增数据项页面

编辑新增数据项的基本信息，建立数据项。

功能点描述：

数据项名称 | 为新增数据项编辑一个名称，方便寻找数据项
数据项编码 | 为数据项编辑一个编码，方便寻找数据项
数据项类型 | 选择数据项类型确认数据项类型，协助用户管理
行聚合 | 选择数据的聚合方式，管理数据
列聚合 | 选择数据聚合方式，管理数据
数据来源 | 选择数据来源，调出对应索引方式
数据查询语句 | 当选择数据来源为数据库查询时，调出数据查询语句编辑框
预览查询 | 当选择数据来源为数据库查询时，调出数据查询语句编辑界面后，可对编辑好的数据库查询语句进行预览查询，（预览查询：运行查询语句调出查询语句查询目标，验证编写的查询语句是否正确）
查询结果 | 显示数据查询结果，用列表的形式展现结果，验证用户查询目标与查询结果是否一致，查询语句是否有误，确认无误后，点击【确定】保存新增数据项，点击【取消】则撤销本次操作回到数据项界面
修改列名 | 运行数据查询语句，查询出目标结果后，选中一条数据，点击【修改列名】可对选中数据进行列名修改
文本编辑 | 在新增数据项时若选择数据来源为【文本编辑】则调出文本编辑框，可对该新增数据项文本内容进行编辑，编辑完成后点击【确定】保存此次编辑内容，点击【取消】撤销本次操作回到数据项界面
表格 | 在新增数据项时若选择数据来源为【表格】则调出表格编辑框，可对该新增数据项数据以表格的形式进行编辑，点击【确定】保存本次编辑，点击【取消】撤销本次编辑回到数据项界面
新增列 | 在【表格】编辑框中，点击【新增列】调出添加数据列界面，输入列名，该界面有持续添加功能，输入列名后可在其下方框中勾选，勾选后可持续添加数据列，编辑完成列名后，点击【添加】执行添加操作，为表格添加一个或多个列名
删除列 | 当表格中有的列无用或编辑错误时，点击【删除列】调出删除数据列界面，选中删除目标列名点击【删除】，从表格中删除选中列，点击【取消】撤销此次操作回到新增数据项界面
新增行 | 当表格中不止一条数据时，点击【新增行】在表格中增加一行可编辑空间，供用户编辑
删除行 | 当有数据无效或行数添加过多时，选中无效数据行点击【删除行】删除选中数据所在行
设置列宽 | 当数据内容过多列与列之间间距过小，内容编辑不下是，可点击【设置列宽】调出设置列宽界面，该界面显示内容，编号、列名、宽度百分比，列名后对应列宽度百分比，可对选中列宽度百分比值进行编辑，编辑完成后单击击其他出可保存，其他列百分比自动调整，使总和保持100%，点击【确定】保存此次设置，点击【取消】撤销此次操作回到新增数据项界面，保持表格数据不变


6.4.4 报表管理 - PC帮助文档V2.1.0

6.4.4 报表管理

点击【报表管理】进入到报表管理模块。报表管理模块包含新增、修改和删除报表等功能。

选择一个分组，点击新增报表按钮，调出上传模板文件界面

点击 [image] 调出路径设置界面设置路径调出模板文件，等待进度条读完后进入【编辑报表】界面

编辑完成报表信息后点击【确定】确认此次操作，点击【取消】撤销此次操作回到上传界面，完成报表编辑后点击上传界面【关闭】完成报表模板上传操作。


7 前台项目 - PC帮助文档V2.1.0

7 前台项目

在后台管理员新建用户、EPS负责人新建项目，项目经理设置项目用户并分配权限等操作已经完成的基础上，就可以进行前台项目流程的操作了。

项目用户登录前台进行项目工作，登录界面如下：

说明:如果勾选进入最近项目,用户登录以后,界面显示:如下图

说明：如果木有勾选进入最近项目，则登录后到选择项目界面，见下图:

项目管理流程：


7.1 测试需求 - PC帮助文档V2.1.0

7.1 测试需求

每一个项目的开始，都是由于需求的存在，项目要做的第一件事就是创建需求。

需求管理流程:


7.1.1 创建需求 - PC帮助文档V2.1.0

7.1.1 创建需求

点击【测试需求】进入测试需求模块。这里，我们可以通过两种方法添加需求，一种是通过添加子需求，需求分析，创建需求；另一种是导入需求。

方法一：首先，通过添加子需求，我们开始需求分析

添加兄弟需求，点击确定完成添加

添加子需求，点击确定完成添加

点击保存按钮进行保存。需求细分也可以在之后由对应的需求分析人员完成。

方法二：导入需求，首先点击 [image] excel需求导入模板配置，进行需求模板配置，选择属性对应列，添加，保存：

需求模板配置完以后，设置与模板相同格式的excel需求文档，点击 [image] 需求导入，打开保存。


7.1.2 需求细分 - PC帮助文档V2.1.0

7.1.2 需求细分

当项目交给测试负责人后，测试负责人将带领手下的测试员进行具体的需求分析，通过兄弟需求与子需求进行需求细分。


7.1.3 需求评审 - PC帮助文档V2.1.0

7.1.3 需求评审

在完成需求分析后，如果项目是需要线上评审的项目，那我们需要进行需求评审

点击【个人中心-评审中心】进入到评审中心模块下，点击【需求评审】的“+”按钮。

跳转到需求评审页面， 点击添加需求按钮，添加需要评审的需求

添加完需求之后，点击提交按钮，测试负责人开始评审

测试负责人进入到个人中心-评审中心-待处理流程下评审

点击评审按钮，进入到评审页面，选择处理结果

点击提交按钮，评审结束！


7.2 项目计划 - PC帮助文档V2.1.0

7.2 项目计划

每一个项目，都会有相关任务明细以及任务时间安排等等。当完成需求评审后，我们可以开始制定项目计划了。

点击【项目计划】进入到项目计划模块。


7.2.1 作业管理 - PC帮助文档V2.1.0

7.2.1 作业管理

添加一个作业，通常作业具有完成时间、成本、组织以及资源等属性。

点击添加作业，双击可以修改名称

双击序号可以修改作业的资源、前置任务等信息。


7.2.2 WBS管理 - PC帮助文档V2.1.0

7.2.2 WBS管理

在作业下节点下新增作业，原来的作业节点会自动升级为WBS节点。WBS节点是一组作业的集合，代表了独立的、具有隶属关系/汇总关系的“可交付成果”。

选中作业，点击添加作业


7.2.3 里程碑管理 - PC帮助文档V2.1.0

7.2.3 里程碑管理

里程碑是项目的阶段性的目标，也可以说是阶段任务完成的一个标志。比如说系统集成测试阶段的里程碑可以是系统集成测试报告评审通过。

点击添加里程碑，双击可以修改名称。


7.3 缺陷提交与处理 - PC帮助文档V2.1.0

7.3 缺陷提交与处理


7.3.1 缺陷提交 - PC帮助文档V2.1.0

7.3.1 缺陷提交

项目一旦实施就会有缺陷，缺陷的管理流程如下：

点击【缺陷视图】进入【缺陷视图】页面中，点击 [image] 提交缺陷，出现提交缺陷对话框，提交缺陷，点击确定。

当项目属性下的用例-缺陷强关联选择是，添加缺陷页面关联用例是必输项。


7.3.2 缺陷处理 - PC帮助文档V2.1.0

7.3.2 缺陷处理

还记得之前做的缺陷流程定制么？当缺陷被提交后，根据缺陷状态的不同，将提交到不同的人手中，直到缺陷状态变更为关闭，流程结束。下面仅以测试负责人做一个示例：

测试负责人进入到【个人中心】【缺陷处理】，点击BUG名称 进入缺陷处理

测试负责人确认是否为缺陷后，选择角色和处理人，点击“提交”，将缺陷交给下一个环节的处理人


7.4 项目进度 - PC帮助文档V2.1.0

7.4 项目进度

当项目在执行中的时候，项目经理希望可以看到项目进度，这在哪里呢？因为已经创建了项目计划，所以要对计划进行评审，进入到【个人中心】-【评审中心】，点击项目计划变更评审的“+”按钮

发起项目计划评审

发起评审，评审通过后，就可以点击【项目进度】模块进入到【项目进度】页面

可以在该页面进行工期和百分比的改变，从而达到监控项目进度的目的。


7.5 查看缺陷报告 - PC帮助文档V2.1.0

7.5 查看缺陷报告

在【测试分析】--【缺陷报告】中可以看到有关缺陷的报告


8 特点介绍 - PC帮助文档V2.1.0

8 特点介绍


8.1 独享丰富的甘特图编辑管理 - PC帮助文档V2.1.0

8.1 独享丰富的甘特图编辑管理

标准化的甘特图编辑管理，支持wbs、task、资源管理、费用管理、工期管理、task各种关系管理（FF\FS\SF\SS)，无需使用ms-project就可以轻松管理项目，支持导入xml、mpp格式的项目计划。


8.2 报表与测试分析 - PC帮助文档V2.1.0

8.2 报表与测试分析

ALM支持手工测试日志和测试分析报告，以测试用例为单位来保存测试日志；手工日志支持附件、关联测试用例；支持自定义测试报表；支持多种统计图标，如需求覆盖率图、测试用例完成的比例分析图、缺陷分布情况等。支持UAT报告，

在ALM软件生命周期管理工具中执行测试用例、提交缺陷等都会自动产生各种统计图表，用户可直接通过这些图表查看最终执行的结果。


8.3 项目群管理 - PC帮助文档V2.1.0

8.3 项目群管理

支持创建企业项目组织，管理项目群，并且在项目群下项目实施管理，资源分配以及实时监控。支持多项目的项目组合管理-----项目群管理。支持通过EPS来管理多项目组合与项目群。


8.4 支持全流程的测试管理 - PC帮助文档V2.1.0

8.4 支持全流程的测试管理

支持覆盖全测试流程的测试管理；支持自定义功能测试、系统测试等测试流程；支持测试目标、测试需求并建立完善的测试计划；支持通过建立测试需求、设计测试用例、测试集、测试计划、发现bug后提交bug至缺陷管理模块中来完成对整个测试流程的管理。


8.5 资源与费用管理 - PC帮助文档V2.1.0

8.5 资源与费用管理

支持人工资源，非人工资源与材料管理，并对资源费用自动计算，支持按部门，按资源角色对人工资源进行管理。支持对部门级和项目级的预期分解以及支出分解，实现预算管理：预算创建，预算调整与审批，预算分解，未分配预算管理。


8.6 项目计划管理 - PC帮助文档V2.1.0

8.6 项目计划管理

支持甘特图项目计划，查看更直观；支持项目计划的直接创建与编辑，同时也支持对WBS进行分配协同编辑；支持当前项目项目范围管理，项目合同管理，项目里程碑，项目资源分配等；支持项目计划分析，以日历形式显示资源在每一个任务下的计划工期以及该资源的总计划工期，分析人力资源分配是否合理


8.7 项目进度管理 - PC帮助文档V2.1.0

8.7 项目进度管理

ALM支持通过跟踪甘特图来标识项目状态。根据甘特图进行资源报工和实时跟踪。并且对项目进度进行分析，以便更好的实时监控项目进度。并且对项目产生的风险与问题有实际的参考依据.


8.8 丰富的项目分析 - PC帮助文档V2.1.0

8.8 丰富的项目分析

支持通过资源分类码、作业分类码对项目过程分析。获得项目的作业分类百分比、资源占用百分比、项目执行偏差分析表等信息，对于积累项目资产，具有重要的价值和意义。支持通过显示柱状图的不同颜色分析项目计划中资源分配是否合理，项目计划是否合理，用饼状图显示项目各阶段工期是否合理。


8.9 支持缺陷管理 - PC帮助文档V2.1.0

8.9 支持缺陷管理

ALM支持管理bug的整个生命周期；支持自定义多个角色、自定义用户、自定义缺陷管理流程；支持自定义过滤器，管理隶属于自己的缺陷；支持自定义公共过滤器；支持实时邮件的功能，在关注的缺陷发生状态改变时，发邮件通知给关注人；支持缺陷列表的导出、自定义缺陷报告、缺陷合并修改；支持缺陷与测试用例关联。


9 常见问题 - PC帮助文档V2.1.0

9 常见问题


9.1 PC安装问题 - PC帮助文档V2.1.0

9.1 PC安装问题


9.1.1 PC安装包默认数据信息？ - PC帮助文档V2.1.0

9.1.1 PC安装包默认数据信息？


9.1.1.1 安装包默认的用户名和密码？ - PC帮助文档V2.1.0

9.1.1.1 安装包默认的用户名和密码？

PC安装包默认的用户名：manager ，密码：111111


9.1.1.2 安装包默认的数据库端口号以及数据库服务名称？ - PC帮助文档V2.1.0

9.1.1.2 安装包默认的数据库端口号以及数据库服务名称？

PC数据库默认端口是3305，服务名称是mysql_alm


9.1.1.3 安装包默认的服务端口？ - PC帮助文档V2.1.0

9.1.1.3 安装包默认的服务端口？

PC安装包默认服务端口是8008


9.1.2 如何修改PC的默认服务端口号 - PC帮助文档V2.1.0

9.1.2 如何修改PC的默认服务端口号

在PC安装路径......\PC\apache-tomcat-7.0.56\conf下找到server.xml文件并打开

将文件中的这两个端口号更改为想要的端口号即可。


9.1.3 安装时未安装数据库如何手动导入数据库表信息 - PC帮助文档V2.1.0

9.1.3 安装时未安装数据库如何手动导入数据库表信息

1）将PC安装目录下的alm_base.sql和flow_commen.sql两个文件导入MYSQL中

2）将PC安装目录…\PC\apache-tomcat-7.0.56\webapps\ProjectCenter\WEB-INF

下的数据库配置文件pmhibernate.cfg.xml中的数据库端口号、用户名、密码改为步骤1）中导入sql文件的数据库的端口号、用户名和密码，修改完成后重启tomcat即可使用。


9.1.4 为什么一键安装报PC服务启动失败？ - PC帮助文档V2.1.0

9.1.4 为什么一键安装报PC服务启动失败？


9.1.4.1 启动报-8错误 - PC帮助文档V2.1.0

9.1.4.1 启动报-8错误

如果使用的是win8系统，建议更换为win7系统；如果是win7系统的话，因为权限不够导致，建议使用超级管理员用户来操作;如果使用的是虚拟机，可通过申请LIC解决此问题。


9.1.4.2 启动Tomcat，启动信息提示有拒绝访问现象 - PC帮助文档V2.1.0

9.1.4.2 启动Tomcat，启动信息提示有拒绝访问现象

在Tomcat启动中有拒绝访问的提示，这种可能是由于在win7系统下权限不够造成的。

有两种解决办法：

用管理员身份启动PC服务

步骤：右击安装完成的PC快捷方式“启动PC.bat”，选择以管理员身份运行

以管理员身份启动cmd在控制台上启动该服务

点击“开始菜单”，选择弹出项目中的“运行（R）…”，在运行弹出窗口输 入“cmd” ，

在弹出的cmd控制台输入：cd D:\Program Files (x86)\Spasvo\PC\apache-tomcat-7.0.56\bin（该路径是：“启动PC.bat”所在安装 路径）进入到目录后运行“启动PC.bat”就能正常启动。详细见下图


9.1.5 服务启动成功，无法成功登录到系统中？ - PC帮助文档V2.1.0

9.1.5 服务启动成功，无法成功登录到系统中？


9.1.5.1 无法正常打开登录界面 - PC帮助文档V2.1.0

9.1.5.1 无法正常打开登录界面

PC登录界面采用flash相关技术，如果系统没有安装flash就有可能出现打不开登录界面，此时可从flash官方网站上下载最新flash，或者在PC的安装目录下有flash插件直接安装，然后重新启动浏览器即可。


9.1.5.2 输入正确用户名信息登录失败 - PC帮助文档V2.1.0

9.1.5.2 输入正确用户名信息登录失败

PC输入安装默认的账号信息manager 密码：111111登录不上去有可能是由于安装过程中数据库表信息导入失败，可通过手动导入数据库表信息解决此问题。详细步骤参照该文档1.3章节。


9.2 PC使用问题 - PC帮助文档V2.1.0

9.2 PC使用问题


9.2.1 后台管理 - PC帮助文档V2.1.0

9.2.1 后台管理


9.2.1.1 不添加公司以及部门能否成功添加用户？ - PC帮助文档V2.1.0

9.2.1.1 不添加公司以及部门能否成功添加用户？

由于在真实的项目中，不可能存在游离于企业与部门之外的人员，所以我们系统的业务逻辑是必须要先增加公司和部门才能添加用户。当然如果不想使用我们的平台管理这些可以用我们安装包里面带的一个初始数据直接添加用户。


9.2.1.2 PC是否支持批量导入用户 - PC帮助文档V2.1.0

9.2.1.2 PC是否支持批量导入用户

后台管理-用户管理支持批量导入用户模板下载，下载模板以后填写好相关信息以后支持直接导入到系统中。


9.2.1.3 PC管理的用户能否删除？ - PC帮助文档V2.1.0

9.2.1.3 PC管理的用户能否删除？

用户分两种，一种是新增的用户从来没有登录过系统既是最后登录时间为空；则支持删除。还有一种是已经登录过系统既已经被判定成为使用有效用户，该用户无法删除。


9.2.1.4 什么是EPS管理？ - PC帮助文档V2.1.0

9.2.1.4 什么是EPS管理？

Enterprise Project Structure(EPS)的缩写，即企业项目结构。EPS管理就是用来系统整合并管理整个公司的项目，确保企业中的每个项目都必须包含在EPS节点中，具体项目可以存在于任一EPS节点，每个节点可以包含多个项目。


9.2.1.5 日历管理是管理什么的？ - PC帮助文档V2.1.0

9.2.1.5 日历管理是管理什么的？

后台的日历管理是管理所有项目的默认日历的，既是一个全局的初始默认值，新建的所有项目默认都是该日历。


9.2.2 管理视图 - PC帮助文档V2.1.0

9.2.2 管理视图


9.2.2.1 针对不同的项目可以进行不同的日历管理吗？ - PC帮助文档V2.1.0

9.2.2.1 针对不同的项目可以进行不同的日历管理吗？

PC除了后台管理全局的默认日历管理外，新建完项目以后可以修改针对这个项目的所独属于这个项目的日历，该日历是这个项目私有的不会对其他项目以及全局默认项目日历进行改动。


9.2.2.2 项目属性希望新增加一个属性可以实现吗? - PC帮助文档V2.1.0

9.2.2.2 项目属性希望新增加一个属性可以实现吗?

例如在项目落地实施的时候，可能由于项目坐落于不同的地方，希望有一个项目地点来记录，这样PC可以做到吗？PC管理视图-综合管理-属性定制可以进行项目属性的定制。能够实现针对不同的项目需求实现不同的属性定制。同时，PC的属性定制模块不仅支持项目属性自定义还支持缺陷、需求、计划属性的自定义。

注意：自定义属性一旦被项目引用还有就不可再进行修改与删除操作。


9.2.2.3 项目的缺陷流程可以定制吗？ - PC帮助文档V2.1.0

9.2.2.3 项目的缺陷流程可以定制吗？

PC初始数据中会自带一个缺陷流程，当我们感觉这个缺陷流程不符合我们项目的缺陷处理流程时，我们就可以根据自己的缺陷处理流程在PC管理视图-综合管理-缺陷流程定制模块配置适合于自己项目的缺陷流程。

注意：缺陷流程一旦被引用在项目中之后就不可再进行修改。


9.2.2.4 项目文档可以统一管理吗？ - PC帮助文档V2.1.0

9.2.2.4 项目文档可以统一管理吗？

一般在一个项目中都会有较多的文档，为了防止文档管理混乱的问题，PC提供了项目文档管理模块，项目负责人可以在管理视图-综合管理-文档管理中对项目文档进行上传、下载、更新操作，并可将文档上传到SVN进行统一管理。

在使用SVN文档管理功能之前，首先要进行SVN地址配置，可在PC的安装目录....\PC\apache-tomcat-7.0.56\webapps\ProjectCenter\WEB-INF\classes 下找到

“flowConfig.properties”文件进行配置。


9.2.2.5 项目文档可以进行归档管理吗？ - PC帮助文档V2.1.0

9.2.2.5 项目文档可以进行归档管理吗？

当项目结项后，项目文档可以进行归档管理。在PC管理视图-综合管理-文档管理中选中已经结项的项目节点，点击归档按钮即可将该项目的文档归档。

注意：项目文档归档操作不可逆，请谨慎操作。


9.2.2.6 如何快速创建项目？ - PC帮助文档V2.1.0

9.2.2.6 如何快速创建项目？

PC中提供了两种创建项目的途径：新增项目和模板创建项目

1）新增项目

EPS负责人可以登录管理视图-综合管理-项目管理中选中EPS节点，点击新增项目，编辑完成项目信息后即可创建项目。

2）模板创建项目

当我们想以现有项目为模板创建项目时，PC也提供给我们了模板创建项目的功能，以模板创建的项目会引用模板项目的团队人员组织。


9.2.2.7 可以查看部门资源或企业资源的使用情况吗？ - PC帮助文档V2.1.0

9.2.2.7 可以查看部门资源或企业资源的使用情况吗？

为了使相关负责人了解部门资源及企业资源使用是否合理，PC提供在管理视图-项目报表中查看部门资源曲线、企业资源曲线查看的功能。


9.2.2.8 可以自动生成测试报告文档吗？ - PC帮助文档V2.1.0

9.2.2.8 可以自动生成测试报告文档吗？

当一个项目测试完成想要生成测试报告时，可以选择在PC管理视图-测试报表中使用数据项和报表管理模块快速生成相应的测试报告。


9.2.3 测试项目 - PC帮助文档V2.1.0

9.2.3 测试项目


9.2.3.1 评审流程可以自定义吗？ - PC帮助文档V2.1.0

9.2.3.1 评审流程可以自定义吗？

PC初始数据中会自带一套评审流程，当我们感觉系统自带的评审流程不满足我们项目的需求时，可以自行设置评审流程。

首先在浏览器中打开http://localhost:8008/ProjectCenter/test/test1.spa网页，用户可在该界面选择相应评审流程进行配置。


9.2.3.2 可以多人同时制定项目计划吗？ - PC帮助文档V2.1.0

9.2.3.2 可以多人同时制定项目计划吗？

一般来说，项目计划都是由项目经理来制定，当项目经理把某一个项目计划分支交由别人负责时，可通过PC项目计划中的协同编辑功能将某个项目计划分配给该计划的负责人。项目计划一旦分配协同编辑后，项目计划的协同编辑负责人对该项目计划有同等于项目经理编辑项目计划的权限。此时项目经理对该分支项目计划无编辑权限，只能取消协同编辑后项目经理才能继续对该项目计划进行编辑。


9.2.3.3 可以引用别的项目中的项目计划吗？ - PC帮助文档V2.1.0

9.2.3.3 可以引用别的项目中的项目计划吗？

当两个项目有相同的项目计划时，在创建第二个项目时可以直接引用上一个项目的项目计划，这样可以给项目负责人带来诸多方便。

假设项目2想要引用项目1的项目计划，那项目1的项目计划在通过项目计划变更评审之后，项目负责人可以登录管理视图-综合管理-计划模板管理模块，将项目1转化为模板，在创建项目2时，勾选模板创建，并选择项目1转化为的模板，项目创建完成之后即可到测试项目中查看，项目2中的项目计划已经成功引用为项目1的项目计划。


9.2.3.4 项目计划已编辑完毕，项目进度一直显示为空怎么办？ - PC帮助文档V2.1.0

9.2.3.4 项目计划已编辑完毕，项目进度一直显示为空怎么办？

项目计划编辑完成后需要进行项目计划变更评审之后才能变更为项目进度。

项目计划变更评审需在测试项目-个人中心-评审中心中完成。


9.2.3.5 那些地方支持批量导入？ - PC帮助文档V2.1.0

9.2.3.5 那些地方支持批量导入？

在PC-测试项目中，多出都可支持直接将excel表中的数据导入项目中，包括测试需求导入、缺陷视图导入；这些操作增加的系统的易用性，在一定程度上减少项目成员的工作量。


9.2.3.6 项目成员如何进项报工及审批？ - PC帮助文档V2.1.0

9.2.3.6 项目成员如何进项报工及审批？

在工时系统模块，项目成员可以选择项目及报工日期，根据作业分类码进行报工，项目负责人可在管理视图-工时系统模块对项目成员的报工进行审批。项目成员的及时报工与审批操作不仅方便相关负责人查看部门资源曲线及企业资源曲线，更可方便管控项目成本。


9.2.3.7 测试需求的状态等等地方没有我想要的选项怎么办？ - PC帮助文档V2.1.0

9.2.3.7 测试需求的状态等等地方没有我想要的选项怎么办？

当我们在编辑测试需求信息时，发现测试需求的状态选项中有“已建议”“已批准”“已实现”“已验证”“已删除”等几个选项，如果这些选项都不能满足我们的项目对测试需求状态的定义时，我们可以在PC后台-数据字典-测试需求状态中添加符合我们项目要求的数据项。同理，在后台-数据字典中“缺陷严重等级”、“缺陷出现频率”、“缺陷类别”……都可以根据我们的需求去编辑数据项，使之能更适应我们的项目要求。