1 产品介绍 - CodeAnalyzer帮助文档

1 产品介绍


1.1 产品介绍 - CodeAnalyzer帮助文档

1.1 产品介绍

l CodeAnalyzer工具简介

CodeAnalyzer（静态代码规范漏洞扫描工具）是上海泽众软件科技有限公司自主研发的，拥有自主产权的，用于实现静态分析、代码走查、代码规范检查以及代码潜在错误分析的白盒测试工具。它是一种脱离编译器的代码静态分析软件产品，在后文中简称CA。

l CA支持的语言

Ø CA目前支持对使用C、C++、JAVA语言编写的应用程序进行静态分析：

Ø 规则内容包含：

Java sun 编程规范

Java sun 安全规则

GJB 5369-2005 航天型号软件C语言安全子集

MISRA-C-2004_工业标准的C编程规范

l CA主要功能

Ø 代码规范化检查

--支持500条内建代码规范（GJB5369,MISRAC:2004,SUN_JAVA）

--支持用户自定义代码规范，可定制化的代码规范检查机制（实现IRULE接口）

Ø 代码安全检查

--内存泄露

--未访问变量声明

--无限循环

--其它代码安全隐患检测

Ø 测试报告

Ø 对外接口

l CA特点

Ø 基于编译的，非基于模式的

Ø 与平台无关的检查

Ø 支持语义级检查规则

Ø 支持多语言，包括C，JAVA,C++

Ø 支持多平台，适用于Windows，Linux

Ø 提供了规则自定义功能，用户可以按照制定自己的规则并可以配置生效


1.2 服务支持 - CodeAnalyzer帮助文档

1.2 服务支持

我们通过在线QQ、微信、电话、电子邮件为您提供支持与服务，您也可访问我们的网站http://www.spasvo.com/寻求帮助；为保证服务质量，确保有效地解决用户的问题，保障用户的项目实施进度，技术支持仅向授权用户和授权试用用户提供。请您在联系泽众技术支持时，告知您的单位名称和服务代码。

技术支持
    电话：021-60725088-8007

传真：021-60725088-8017
    电子邮件：support@spasvo.com

QQ：1404189128

泽众微信公众号

产品服务

有关培训、产品购买及试用授权方法的问题，请与销售代表联系，或联系泽　众咨询热线。

电话：021-60725088-8006

传真：021-60725088-8017

电子邮件: sales@spasvo.com


1.3 系统要求 - CodeAnalyzer帮助文档

1.3 系统要求

在使用本软件之前请确认系统配置符合以下条件：

Ø 操作系统要求：Windows(32位/64位) 、Linux；

Ø 内存要求：建议使用2G内存；

Ø 磁盘空间要求：不少于180M剩余磁盘空间；


2 产品安装 - CodeAnalyzer帮助文档

2 产品安装


2.1 产品安装 - CodeAnalyzer帮助文档

2.1 产品安装

Ø 进入本公司网站www.spasvo.com注册账户。

Ø 注册之后登录即可下载CodeAnalyzer。

Ø 双击安装图示,安装图示如下

Ø 弹出如下提示框，并按照提示安装完成。

Ø CA的试用期为15天，是通过LicenseServer来控制使用天数的。如果想长期使用需要申请license。

申请license的过程：

1.双击安装Install_LicenseServer

2.双击生成的快捷方式

3.右击在电脑右下角显示的图标

4.点击Apply License，选中路径保存生成的req文件

Ø 将生成的req文件上传到公司网站上，我们会通过注册时的邮箱将license 发送至您邮箱。

Ø 收到license文件后打开LicenseServer，右击右下角显示图标->点击“Import License”，提示导入成功，重启后生效

Ø 配置License Server端口，此端口默认是：22211，如果冲突可以更改端口号。点击确定完成配置，提示重启软件后生效。如图所示

Ø 进入CA点击“产品”，选择“License服务器配置”，弹出如下图所示窗口。

Server IP应输入license Server服务器IP地址，Port端口：license Server服务器的端口。

点击确定完成配置，提示重启软件后生效。


3 功能简介 - CodeAnalyzer帮助文档

3 功能简介


3.1 进入程序 - CodeAnalyzer帮助文档

3.1 进入程序

1. 点击 [image] 进入选择工作空间界面

说明:

工作空间为CA自行选择的工作空间，不要更改，否则会由于缺少文件而出现错误；

初次进入时会要求选择工作空间，之后再进入不需要选择空间，默认已使用的工作空间；

2. 点击确认进入CA，显示CA的工作区域


3.2 切换工作空间 - CodeAnalyzer帮助文档

3.2 切换工作空间

1. 点击文件下的切换工作空间，如下图所示

2. 弹出选择工作空间对话框，如下图所示

3. 选择工作空间路径，点击确定，完成工作空间的切换


3.3 新建项目 - CodeAnalyzer帮助文档

3.3 新建项目

l 方式一：

1. 点击文件下的新项目，如下图所示

1.弹出新建项目对话框，如下图所示，用户根据自己需求填写项目名，选择项目字符集，项目类型。点击浏览选择源文件路径，头文件路径和库文件路径。（路径为要分析的项目的源代码的路径）（此处以C代码，UTF-8为例）

2.点击“下一步”按钮，进入规则包选择页面，如下图所示

4.点击确定完成创建项目

l 方式二：

1.在工具栏点击 [image] 按钮新建项目，弹出新建项目对话框，后续输入操作与方式一相同

l 方式三：

1.选中已经存在的项目，右击->创建项目，弹出新建项目对话框


3.4 导入项目 - CodeAnalyzer帮助文档

3.4 导入项目

l 方式一：

1.点击文件下的导入项目，如下图所示

2.弹出导入项目对话框，如下图所示（项目列表中的项目是已存在工作空间，但是不在界面内显示的项目，若想将项目导入，需先拷贝项目到工作空间下，才可导入。）

全部选中：即项目列表内所有项目全部勾选；

全部取消：即取消所有已勾选的项目；

3.勾选需要导入的项目，点击确定按钮完成项目的导入

l 方式二：

1.在工具栏内点击 [image] 按钮导入项目


3.5 关闭项目 - CodeAnalyzer帮助文档

3.5 关闭项目

l 方式一：

1.选中要关闭的打开状态的项目，点击文件下的关闭项目，如下图所示，完成项目的关闭，已关闭的项目不能再展开查看源码，不能进行分析

l 方式二：

1.选中要关闭的打开状态的项目，右击->关闭项目，如下图所示，完成项目的关闭

l 方式三：

1.选中要关闭的打开状态的项目，点击 [image] 按钮关闭项目


3.6 打开项目 - CodeAnalyzer帮助文档

3.6 打开项目

l 方式一：

1.选中要打开的关闭状态的项目，点击文件下的打开项目，如下图所示，完成项目的打开，只有打开的项目才可以进行分析

l 方式二：

1.选中要打开的关闭状态的项目，右击->打开项目，如下图所示，完成项目的打开

l 方式三：

1.选中要打开的关闭状态的项目，点击 [image] 按钮打开项目


3.7 删除项目 - CodeAnalyzer帮助文档

3.7 删除项目

l 方式一：

1.选中要删除的项目，点击文件下的删除项目，如下图所示，完成项目的删除

2.弹出删除项目选择框

同时删除项目源代码：在界面内移除项目的同时删除工作空间下相关源代码；

只删除项目，不删除项目源代码：只在界面内移除项目，不删除工作空间下的项目信息，以后若需要，可通过导入项目的方式加载到工作区域；

3.选择删除的类型后，点击确认完成项目的删除

l 方式二：

1.选中要删除的项目，右击->删除项目，如下图所示，完成项目的打开


3.8 分析项目 - CodeAnalyzer帮助文档

3.8 分析项目

l 方式一：

1.选中项目，右击->设置主项目，如下图所示，完成主项目的设置

2.点击 [image] 按钮，分析项目，或是点击规则扫描->分析项目

3.弹出解析项目对话框，如下图所示

4.选中勾选框[用户指定名称…]，填写执行名称，点击确认

5.弹出解析项目监视窗口，如下图所示，可对其进行暂停，开始和停止解析操作

6.点击 [image] 可进行清空，关闭当前窗口，关闭所有操作窗口操作

l 方式二：

1.选中项目，右击->分析项目，如下图所示，进行项目的分析。（分析项目都必需要先设置主项目）


3.9 分析文件 - CodeAnalyzer帮助文档

3.9 分析文件

1. 展开项目，可双击项目名称，或右击->展开，然后点击 [image] ，对项目进行展开（或直接右击->展开全部）

2. 选中要分析的文件，右击->分析文件

3. 弹出解析文件监视窗口，如下图所示

4. 点击 [image] 可查看文件的问题列表

5. 点击 [image] 可进行清空，关闭当前窗口，关闭所有操作窗口操作


3.10 分析报告 - CodeAnalyzer帮助文档

3.10 分析报告

l 方式一：

1. 在弹出的解析项目监视窗口中点击 [image] ，弹出测试分析报告，如下图所示

2. 双击单个文件可以查看该文件下的问题，点击问题可以显示出现该问题的行列明细

3. 点击问题总表，弹出如下对话框，可以查看所有问题列表

4. 点击打开问题树，弹出问题面板，双击 [image] ，出现问题数量数量明细

5. 点击导出问题，可以对问题进行导出

l 方式二：

1.设置想要查看的项目为主项目，点击快捷状态工具栏的 [image] ，查看测试分析报表

用户可根据分析报告中的提示内容来查找和修改有问题的代码


3.11 规则配置 - CodeAnalyzer帮助文档

3.11 规则配置

1. 点击 [image] ，或是点击规则扫描->规则配置，如下图所示

2. 弹出如下对话框，可以对规则进行添加，删除等操作

3. 点击确定完成规则的配置


4 常见问题 - CodeAnalyzer帮助文档

4 常见问题


4.1 创建项目 - CodeAnalyzer帮助文档

4.1 创建项目

1）创建项目时，注意选择想配对的项目字符集合类型，例如C语言选择Big5,而Java则需要选择UTF-8

2）当导入的项目代码源文件中，有src与lib文件夹，则需要将相应的源文件路径和库文件路径配置到相对应的文件夹。

3）如果没有src与lib文件夹，则导入全部源代码文件